Jump to content



Photo

BT50 EGR cooler & EGR valve replacement


  • Please log in to reply
15 replies to this topic

#1 ANT1967

ANT1967

    Power Band in 1st Gear

  • Full Member
  • PipPip
  • 12 posts
  • Location:Melbourne outer west

Posted 17 March 2017 - 01:49 PM

Howdy all ,

I've got a BT 50 3.2 4WD Jan. 2013 with 118000kms .

Engine light coming on & DSC light coming on often

Taken to Mazda - Diagnosis - Coolant leaking from EGR cooler

Require new EGR Cooler AND EGR valve also......!!

Obviously the most concerning thing is the DSC light / anti skid kicking in which makes it not driveable

Just interested if anyone else has had these issues & have any advice .

Mazda have quoted me approx. $2500 to fix which I guess is my biggest beef & interested in others thoughts or alternatives

Safe travels

Anthony

Edited by ANT1967, 17 March 2017 - 01:54 PM.


#2 bucko

bucko

    Donut King

  • Full Member
  • PipPipPipPip
  • 142 posts
  • Location:NR Perth

Posted 17 March 2017 - 10:17 PM

Is it over heating?
I would check all hoses to intercooler as a leak or split hose will cause the same.
If egr cooler is the problem, then to save a few dollars you could bypass coolant hoses to egr cooler and install blanking plate.

#3 ANT1967

ANT1967

    Power Band in 1st Gear

  • Full Member
  • PipPip
  • 12 posts
  • Location:Melbourne outer west

Posted 18 March 2017 - 09:30 AM

G'day Bucko,

Thanks for the reply

Hope all is well over west

The car isn't overheating , but I appreciate you asking

I've read a fair bit about the blanking plate & EGR delete

Will probably approach some reputable diesel mechanics

#4 Gof

Gof

    Power Band in 2nd Gear

  • Full Member
  • PipPipPip
  • 46 posts

Posted 19 March 2017 - 02:55 PM

Is it using any coolant? If not I would be looking for a boost leak, the hose from the intercooler to inlet manifold is the usual fault, the next is a split tube in the intercooler, the turbo to intercooler hoses seem to be the least reported.

#5 ANT1967

ANT1967

    Power Band in 1st Gear

  • Full Member
  • PipPip
  • 12 posts
  • Location:Melbourne outer west

Posted 20 March 2017 - 05:55 PM

G'day Gof ,

Thanks for posting your thoughts

I've booked the car in for a complete 2nd opinion this Friday & certainly have mentioned double checking hoses , coolant leaks etc.

Will post the diagnosis & outcome later in the week

Anthony

#6 Wartim

Wartim

    60 kph

  • Full Member
  • PipPip
  • 18 posts

Posted 24 March 2017 - 07:53 PM

watching with interest



#7 jjboy

jjboy

    60 kph

  • Full Member
  • PipPip
  • 21 posts

Posted 01 April 2017 - 06:33 AM

Very keen to hear what the issue was?



#8 ANT1967

ANT1967

    Power Band in 1st Gear

  • Full Member
  • PipPip
  • 12 posts
  • Location:Melbourne outer west

Posted 03 April 2017 - 11:17 AM

Howdy ,

I took the car 10 days ago for a 2nd opinion to a highly reputable 4WD shop .
He put the car on the tuner & the Main error showing up was .... " Engine Gas Retic. Control closed "

After a sheet load of high revs , Mechanic could hear the EGR valve slightly open & close .

In his opinion the valve seems operational , just blocked ?

I was recommended to put in " Fuelshot 4000 " 80 ml per 80 litres of fuel . I can't find much on Fuelshot , but I presume there is
Other similar products that do the same , ie: kill Diesel bug etc....

Some info. Here http://www.keltonren...ry/11-fuel-shot

The idea of the additive is to assist the valve to open correctly . I am to return after 1 month to check further .




As of today the original problem of Anti skid light / limp mode kicks in every morning after I drive about 200 metres .

Turn car off , it goes off then engine light stays on generally until the car is warm or done a few kms .

I look after my mother full time , so I'm not doing many kms.



The jury is still out ...........

Edited by ANT1967, 03 April 2017 - 01:51 PM.


#9 ANT1967

ANT1967

    Power Band in 1st Gear

  • Full Member
  • PipPip
  • 12 posts
  • Location:Melbourne outer west

Posted 11 May 2017 - 10:33 AM

G'day ,

I haven't used the BT much in the last month

Next week I'm getting a new EGR valve fitted .

Will advise details , costs & results etc once completed

#10 Hoyks

Hoyks

    100 kph

  • Full Member
  • PipPipPipPip
  • 160 posts

Posted 12 May 2017 - 03:42 PM

It sounds similar to the symptoms mine had.

 

The dealer stripped the induction system and blamed the EGR blanking plate I had fitted. I thought it was strange as I'd had no issue with it for around 30000km. They also replaced the Bluetooth module, not that I noticed anything wrong with it.

 

All re-assembled and I haven't had an issue since, so I have no real idea what the problem was.



#11 Tiny2829

Tiny2829

    Newbie

  • Full Member
  • Pip
  • 6 posts
  • Location:NSW
  • Interests:rodeo, camping, fishing, off roading

Posted 12 May 2017 - 09:10 PM

isnt this part of what the catch cans prevent?



#12 ANT1967

ANT1967

    Power Band in 1st Gear

  • Full Member
  • PipPip
  • 12 posts
  • Location:Melbourne outer west

Posted 13 May 2017 - 05:21 PM

isnt this part of what the catch cans prevent?








Overall the car has performed well , particularly the first 100,000 kms.

I bought the car Jan. 2013 mainly to tow a 3000kg caravan , which back then we were living in & travelling
full time .

Being a bit naive about diesels & a combination of heavy towing , YES I think a catch can could have avoided me having to replace the EGR .

Car is booked in Tuesday , looking forward to getting it done & it fixing the issues .

#13 Hoyks

Hoyks

    100 kph

  • Full Member
  • PipPipPipPip
  • 160 posts

Posted 13 May 2017 - 10:48 PM

I don't think a catch can would have helped. The EGR valve is upstream of the air intake, and they is where the oil comes in. The area around the valve should only have a light dusting of carbon, similar to what is in the exhaust.


  • ANT1967 likes this

#14 ANT1967

ANT1967

    Power Band in 1st Gear

  • Full Member
  • PipPip
  • 12 posts
  • Location:Melbourne outer west

Posted 24 May 2017 - 03:47 PM

Howdy ,

Last Tuesday 16/5 had the car in & the EGR valve was replaced .

All codes were cleared & instantly the car was / is purring along & im happy with the outcome .

Overall , with quite a bit of diagnosis time etc. the cost for replacement , supply & fit $700 .

I have the original EGR & taken a couple of photos .

Going back to my original post , If I would have done what Mazda diagnosed / quoted @ $2500 , it probably would have fixed the issue . BUT the 4x4 place where I took the car could not find any leaks or codes relating to the cooler .

It's taken about 10 weeks , but I'm glad I sought out other opinions & had the car fixed elsewhere .

Just for the record , the original error codes were :

- PO42F - Exhaust Gas Retic. Closed .
- UO401 - Invalid data from ECM .


Cheers

Anthony

Attached Files


Edited by ANT1967, 24 May 2017 - 03:51 PM.


#15 pootman

pootman

    Newbie

  • Member
  • Pip
  • 4 posts

Posted Yesterday, 04:37 PM

are you in Sydney & if so who was the repairer you used?

 

Cheers



#16 ANT1967

ANT1967

    Power Band in 1st Gear

  • Full Member
  • PipPip
  • 12 posts
  • Location:Melbourne outer west

Posted Yesterday, 07:56 PM

are you in Sydney & if so who was the repairer you used?
 
Cheers







G'day Pootman

I'm in Melbourne




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users