Jump to content



Photo

BT50 EGR cooler & EGR valve replacement


  • Please log in to reply
25 replies to this topic

#1 ANT1967

ANT1967

    Second Gear

  • Full Member
  • PipPipPip
  • 26 posts
  • Location:Melbourne outer west
  • Interests:Travelling
    Prospecting

Posted 17 March 2017 - 01:49 PM

Howdy all ,

I've got a BT 50 3.2 4WD Jan. 2013 with 118000kms .

Engine light coming on & DSC light coming on often

Taken to Mazda - Diagnosis - Coolant leaking from EGR cooler

Require new EGR Cooler AND EGR valve also......!!

Obviously the most concerning thing is the DSC light / anti skid kicking in which makes it not driveable

Just interested if anyone else has had these issues & have any advice .

Mazda have quoted me approx. $2500 to fix which I guess is my biggest beef & interested in others thoughts or alternatives

Safe travels

Anthony

Edited by ANT1967, 17 March 2017 - 01:54 PM.


#2 bucko

bucko

    100 kph

  • Full Member
  • PipPipPipPip
  • 156 posts
  • Location:NR Perth

Posted 17 March 2017 - 10:17 PM

Is it over heating?
I would check all hoses to intercooler as a leak or split hose will cause the same.
If egr cooler is the problem, then to save a few dollars you could bypass coolant hoses to egr cooler and install blanking plate.

#3 ANT1967

ANT1967

    Second Gear

  • Full Member
  • PipPipPip
  • 26 posts
  • Location:Melbourne outer west
  • Interests:Travelling
    Prospecting

Posted 18 March 2017 - 09:30 AM

G'day Bucko,

Thanks for the reply

Hope all is well over west

The car isn't overheating , but I appreciate you asking

I've read a fair bit about the blanking plate & EGR delete

Will probably approach some reputable diesel mechanics

#4 Gof

Gof

    Zoom Zoom Zoom

  • Full Member
  • PipPipPip
  • 55 posts

Posted 19 March 2017 - 02:55 PM

Is it using any coolant? If not I would be looking for a boost leak, the hose from the intercooler to inlet manifold is the usual fault, the next is a split tube in the intercooler, the turbo to intercooler hoses seem to be the least reported.

#5 ANT1967

ANT1967

    Second Gear

  • Full Member
  • PipPipPip
  • 26 posts
  • Location:Melbourne outer west
  • Interests:Travelling
    Prospecting

Posted 20 March 2017 - 05:55 PM

G'day Gof ,

Thanks for posting your thoughts

I've booked the car in for a complete 2nd opinion this Friday & certainly have mentioned double checking hoses , coolant leaks etc.

Will post the diagnosis & outcome later in the week

Anthony

#6 Wartim

Wartim

    Gear Change

  • Full Member
  • PipPip
  • 24 posts

Posted 24 March 2017 - 07:53 PM

watching with interest



#7 jjboy

jjboy

    Redline in 1st Gear

  • Full Member
  • PipPip
  • 23 posts

Posted 01 April 2017 - 06:33 AM

Very keen to hear what the issue was?



#8 ANT1967

ANT1967

    Second Gear

  • Full Member
  • PipPipPip
  • 26 posts
  • Location:Melbourne outer west
  • Interests:Travelling
    Prospecting

Posted 03 April 2017 - 11:17 AM

Howdy ,

I took the car 10 days ago for a 2nd opinion to a highly reputable 4WD shop .
He put the car on the tuner & the Main error showing up was .... " Engine Gas Retic. Control closed "

After a sheet load of high revs , Mechanic could hear the EGR valve slightly open & close .

In his opinion the valve seems operational , just blocked ?

I was recommended to put in " Fuelshot 4000 " 80 ml per 80 litres of fuel . I can't find much on Fuelshot , but I presume there is
Other similar products that do the same , ie: kill Diesel bug etc....

Some info. Here http://www.keltonren...ry/11-fuel-shot

The idea of the additive is to assist the valve to open correctly . I am to return after 1 month to check further .




As of today the original problem of Anti skid light / limp mode kicks in every morning after I drive about 200 metres .

Turn car off , it goes off then engine light stays on generally until the car is warm or done a few kms .

I look after my mother full time , so I'm not doing many kms.



The jury is still out ...........

Edited by ANT1967, 03 April 2017 - 01:51 PM.


#9 ANT1967

ANT1967

    Second Gear

  • Full Member
  • PipPipPip
  • 26 posts
  • Location:Melbourne outer west
  • Interests:Travelling
    Prospecting

Posted 11 May 2017 - 10:33 AM

G'day ,

I haven't used the BT much in the last month

Next week I'm getting a new EGR valve fitted .

Will advise details , costs & results etc once completed

#10 Hoyks

Hoyks

    Power Band in 3rd Gear

  • Full Member
  • PipPipPipPip
  • 176 posts

Posted 12 May 2017 - 03:42 PM

It sounds similar to the symptoms mine had.

 

The dealer stripped the induction system and blamed the EGR blanking plate I had fitted. I thought it was strange as I'd had no issue with it for around 30000km. They also replaced the Bluetooth module, not that I noticed anything wrong with it.

 

All re-assembled and I haven't had an issue since, so I have no real idea what the problem was.


  • ANT1967 likes this

#11 Tiny2829

Tiny2829

    Newbie

  • Full Member
  • Pip
  • 6 posts
  • Location:NSW
  • Interests:rodeo, camping, fishing, off roading

Posted 12 May 2017 - 09:10 PM

isnt this part of what the catch cans prevent?



#12 ANT1967

ANT1967

    Second Gear

  • Full Member
  • PipPipPip
  • 26 posts
  • Location:Melbourne outer west
  • Interests:Travelling
    Prospecting

Posted 13 May 2017 - 05:21 PM

isnt this part of what the catch cans prevent?








Overall the car has performed well , particularly the first 100,000 kms.

I bought the car Jan. 2013 mainly to tow a 3000kg caravan , which back then we were living in & travelling
full time .

Being a bit naive about diesels & a combination of heavy towing , YES I think a catch can could have avoided me having to replace the EGR .

Car is booked in Tuesday , looking forward to getting it done & it fixing the issues .
  • powl1all likes this

#13 Hoyks

Hoyks

    Power Band in 3rd Gear

  • Full Member
  • PipPipPipPip
  • 176 posts

Posted 13 May 2017 - 10:48 PM

I don't think a catch can would have helped. The EGR valve is upstream of the air intake, and they is where the oil comes in. The area around the valve should only have a light dusting of carbon, similar to what is in the exhaust.


  • ANT1967 likes this

#14 ANT1967

ANT1967

    Second Gear

  • Full Member
  • PipPipPip
  • 26 posts
  • Location:Melbourne outer west
  • Interests:Travelling
    Prospecting

Posted 24 May 2017 - 03:47 PM

Howdy ,

Last Tuesday 16/5 had the car in & the EGR valve was replaced .

All codes were cleared & instantly the car was / is purring along & im happy with the outcome .

Overall , with quite a bit of diagnosis time etc. the cost for replacement , supply & fit $700 .

I have the original EGR & taken a couple of photos .

Going back to my original post , If I would have done what Mazda diagnosed / quoted @ $2500 , it probably would have fixed the issue . BUT the 4x4 place where I took the car could not find any leaks or codes relating to the cooler .

It's taken about 10 weeks , but I'm glad I sought out other opinions & had the car fixed elsewhere .

Just for the record , the original error codes were :

- PO42F - Exhaust Gas Retic. Closed .
- UO401 - Invalid data from ECM .


Cheers

Anthony

Attached Files


Edited by ANT1967, 24 May 2017 - 03:51 PM.

  • powl1all likes this

#15 pootman

pootman

    Newbie

  • Member
  • Pip
  • 4 posts

Posted 25 May 2017 - 04:37 PM

are you in Sydney & if so who was the repairer you used?

 

Cheers



#16 ANT1967

ANT1967

    Second Gear

  • Full Member
  • PipPipPip
  • 26 posts
  • Location:Melbourne outer west
  • Interests:Travelling
    Prospecting

Posted 25 May 2017 - 07:56 PM

are you in Sydney & if so who was the repairer you used?
 
Cheers







G'day Pootman

I'm in Melbourne

#17 powl1all

powl1all

    60 kph

  • Full Member
  • PipPip
  • 19 posts

Posted 26 June 2017 - 02:18 PM

HI, I have been reading with interest. I have a 2013 Bt50 3.2   At 99,000 kms I blew one the hoses underneath the fuel filter. The common one that blows and has a recall on it. The motor got hot but I turned off and addressed quick. Was replaced and thought all was good. However since then have been returning to Mazda deal with a coolant usage problem. Has used now about 10 litres. No signs of leaks. Pressure tests good. However after long trips I find the coolant level way down, performance great. After suggesting and working through many possibles. We have now decided to replace EGR valve. However after isolating the EGR valve I have noticed this morning that coolant level way down again. Spoke to dealer and now just realised that they had NOT, isolated the cooler. Vehicle now travelled 109,000km.  Mazda have accepted warranty but dealer now wondering if they will accept both. I think a no brainer  This stems from a known warranty problem with these hoses and a recall, which failed also. Has anyone else suffered this problem to. The EGR is not blocked nor does it have a plate fitted. Has had all its services at Mazda. So very hard for them to dish me.  Your thoughts please  



#18 ANT1967

ANT1967

    Second Gear

  • Full Member
  • PipPipPip
  • 26 posts
  • Location:Melbourne outer west
  • Interests:Travelling
    Prospecting

Posted 26 June 2017 - 03:42 PM

HI, I have been reading with interest. I have a 2013 Bt50 3.2   At 99,000 kms I blew one the hoses underneath the fuel filter. The common one that blows and has a recall on it. The motor got hot but I turned off and addressed quick. Was replaced and thought all was good. However since then have been returning to Mazda deal with a coolant usage problem. Has used now about 10 litres. No signs of leaks. Pressure tests good. However after long trips I find the coolant level way down, performance great. After suggesting and working through many possibles. We have now decided to replace EGR valve. However after isolating the EGR valve I have noticed this morning that coolant level way down again. Spoke to dealer and now just realised that they had NOT, isolated the cooler. Vehicle now travelled 109,000km.  Mazda have accepted warranty but dealer now wondering if they will accept both. I think a no brainer  This stems from a known warranty problem with these hoses and a recall, which failed also. Has anyone else suffered this problem to. The EGR is not blocked nor does it have a plate fitted. Has had all its services at Mazda. So very hard for them to dish me.  Your thoughts please  








G'day ,
Thanks for posting this , sounds like similar symptoms to mine .

Did you have any or what were the error codes ?

My coolant level was down slightly but not near minimum

Now the EGR cooler & hoses were all ok

Wonder if the EGR cooler bypasses itself & coolant sits in it ? ( sounds dumb )
  • powl1all likes this

#19 Gof

Gof

    Zoom Zoom Zoom

  • Full Member
  • PipPipPip
  • 55 posts

Posted 26 June 2017 - 07:05 PM

I have heard of the EGR cooler failing and feeding coolant into the motor, it may even have something to with the valve failing.

#20 powl1all

powl1all

    60 kph

  • Full Member
  • PipPip
  • 19 posts

Posted 13 July 2017 - 11:43 AM

Hi Ant 1967

Yes it does sound similar. The update is the local dealer has now replaced the EGR cooler and Valve. They isolated the valve first and it still used water. A big job to do but a week on and no water usage.  Although have not done a big trip.... They also found a water mark around the front of my motor near the thermostat housing. So they are replacing this as well. This has gone on for months and I hope now we are seeing the end.  They showed me the EGR cooler and wow....a very complicated component,well made....My old one was clean to and not blocked either. So my BP fuel must be good.  Will keep you posted mate.

The coolant would go straight out exhaust mate.  The cooler has little tubes running through it. If they are cracked well thats how you loose water. No error codes for me. Also and very important that testing does not always show up faults. Look up UMR engines Brisbane (site) and look at the information on EGR coolers for Rangers/ BT50. Very interesting. A common problem. Although you won't see Mazda or Ford admit this.


Edited by powl1all, 13 July 2017 - 11:47 AM.

  • ANT1967 likes this




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users