Jump to content



Photo

Automatic transmission issues 2013 BT 50


  • Please log in to reply
40 replies to this topic

#1 Wrick

Wrick

    Newbie

  • Full Member
  • Pip
  • 8 posts

Posted 18 October 2015 - 09:56 AM

While driving across the Nullarbor in July 2015, my transmission light came on,  followed by the powertrain light. I had no problems with Mazda in covering the costs and a new auto transmission, but they would not tell me what the problem was. The vehicle had only travelled 20000Kms. The Dealer said that they have had similar problems before ( was asked by head office to check for iron filings in the Transmission oil ) but head office in Melbourne said that it was the first time they had encountered it.

Anyone heard of similar issues with the transmission

 

 



#2 69candy

69candy

    60 kph

  • Full Member
  • PipPip
  • 14 posts

Posted 24 October 2015 - 09:59 PM

Had mine replaced at 37000kms, I just had the trans light come on. Mine would not lock into overdrive, 6 gear would select but the torque converter would not lock in. Crook servo in the trans. While waiting for part, told to keep driving, 3 days later it went in on the back of a truck, as it lost all drive. New trans, cooler and lines fitted



#3 Hammo1951

Hammo1951

    60 kph

  • Full Member
  • PipPip
  • 14 posts

Posted 02 November 2015 - 04:55 PM

I have just had my auto trans and oil cooler replaced at 49,500 km. Trans oil was checked during 50k service and found to be burnt, further checks found iron filings in pan. There have been several in my local area. No problem with Mazda replacing, luckily only have 7 weeks warranty left.



#4 craig1

craig1

    The Zoomiest guy ever

  • Moderator
  • 300 posts

Posted 02 November 2015 - 07:54 PM

How did they check it and why?, somewhere in the b/s it says 1st check at 200,000 km, thanks craig



#5 hig70

hig70

    Zoom Zoom Zoom

  • Full Member
  • PipPipPip
  • 68 posts

Posted 02 November 2015 - 10:04 PM

Hi, Mine was replaced at 38K km's. mine while driving at 85kph would down change to 1st compression locking the rear tyres while the engine hitting the rev limiter. no warning lights.

they wouldnt tell me what the problem was at the time but a few services later they slipped up and told me a solinoid failed.


Edited by hig70, 02 November 2015 - 10:07 PM.


#6 Gazza1

Gazza1

    Second Gear

  • Full Member
  • PipPipPip
  • 38 posts
  • Location:Mid North coast; NSW
  • Interests:Fishing and Touring about Australia with caravan in tow

Posted 08 November 2015 - 06:06 PM

Hi all,

A quick question to those that have had auto trans problems. Were the vehicles used for towing, such as caravans or heavy trailers. I have a 2013 BT50 GT auto and have towed a 2.8T van around a bit and note a few (for want of a better term) "minor" inconsistencies in the way the transmission acts ... but nothing that appears to be very outstanding, like enough to take it back to the dealer and complain.

Has done 40K and runs out of warranty June 2016. Have some concern about it. Can I get the transmission inspected for metal filings/burnt oil etc without a huge expense and primarily not affect warranty?

Any suggestions appreciated.


Edited by Gazza1, 08 November 2015 - 06:08 PM.


#7 bucko

bucko

    100 kph

  • Full Member
  • PipPipPipPip
  • 156 posts
  • Location:NR Perth

Posted 08 November 2015 - 11:34 PM

Hi all,
A quick question to those that have had auto trans problems. Were the vehicles used for towing, such as caravans or heavy trailers. I have a 2013 BT50 GT auto and have towed a 2.8T van around a bit and note a few (for want of a better term) "minor" inconsistencies in the way the transmission acts ... but nothing that appears to be very outstanding, like enough to take it back to the dealer and complain.
Has done 40K and runs out of warranty June 2016. Have some concern about it. Can I get the transmission inspected for metal filings/burnt oil etc without a huge expense and primarily not affect warranty?
Any suggestions appreciated.


Just go to auto transmission shop get a service, I'm going to get done before warranty runs out!

#8 Hammo1951

Hammo1951

    60 kph

  • Full Member
  • PipPip
  • 14 posts

Posted 10 November 2015 - 08:09 AM

Hi Guys, mine was not used for towing, except a box trailer to the tip a couple of times. Have had some minor inconsistencies for last 2 years but have always raised these with service people and ensured they were logged on my history. Thankfully my failure picked up at the 50k service after i reported a minor performance thing and they check oil condition. The gearbox oil was checked at 40k and all was fine.



#9 willockwood

willockwood

    Newbie

  • Member
  • Pip
  • 2 posts

Posted 23 November 2015 - 03:16 PM

Have just put my 2013 BT50 GT into dealer for replacement transmission after requesting inspection at last service (47000km).  Service manager told me the oil was black and smelt the worst he had come across.  Mazda approved the replacement box same day as service.  Lucky I asked as about to tow 20ft van from Adelaide to Darwin and back !!



#10 Gazza1

Gazza1

    Second Gear

  • Full Member
  • PipPipPip
  • 38 posts
  • Location:Mid North coast; NSW
  • Interests:Fishing and Touring about Australia with caravan in tow

Posted 30 November 2015 - 04:13 PM

Hi "Willockwood".

Were you having any significant issues with the transmission to request an inspection of the transmission at the last service? ... If so what were they.



#11 Bimota

Bimota

    Newbie

  • Member
  • Pip
  • 3 posts

Posted 01 December 2015 - 07:47 PM

Hi Gazza1,
I too have had some inconsistencies in gear changes whilst towing a 2.7 tonne van. Like you I haven't rushed back to the dealer but I did raise the issue at my last service. Vehicle has only done 12k.
Cheers

#12 seriosdude

seriosdude

    Second Gear

  • Full Member
  • PipPipPip
  • 28 posts

Posted 02 December 2015 - 09:10 AM

Hi guys

 

My BT is now over 3 years old and has just gone in today for 80,000klm service.

Mine has always had a shudder in first gear at around 1,800 revs, (auto) and because we tow a 24ft van - as we live in it, I was starting to get a bit edgy.

 

The Maroochydore Mazda service guy says - "Oh, so you have driven it over rough roads then?" At that point my fist got itchy!!

"I just quietly said "Don't go there mate!"  He asked if I had done anything "after market" on the suspension? 

This guy even tried to tell me that fitting an upgraded stiffer suspension was the cause of my transmission shudder!!

 

I told him of a new owner I had recently met - with just 600klms on the clock and his was doing the same thing.

 

Our Transmission specialist picked it up in the test drive - but couldn't prove anything from the transmission. No faults in the software log, and no vibration from the drive train.I had heard of some overheating issues (particularly when towing) and so got prices on a transmission cooler. Ron Hill Automatics also mentioned that they had come across a lot of Rangers with the same shudder!!

 

They quoted me $1,700 for a fan forced transmission cooler - which I thought was a bit high!

 

I found Davies Craig in Melbourne manufacture transmission coolers - as a kit - available at Bursons Spare Parts - for $289 (incl 9" cooling fan)

You can install them yourself, but my mechanic quote $350 labour. $1,000 less that the Auto Transmission guys.

 

We are on the road for the next 5 years (Tasmania from January for 12 months) - so the last thing I need is a bill for $10,000 to replace the transmission.

 

Mazda tell you lots of fibs - and will ALWAYS try to blame you for the fault.

 

Happy Travelling guys



#13 Wrick

Wrick

    Newbie

  • Full Member
  • Pip
  • 8 posts

Posted 09 December 2015 - 08:09 AM

Hi seriosdude

Can you tell me where you have put the transmission cooler  and is it working effectively. I am getting a bit paranoid because I have brought a Engine Data Scan and the ATF  on a warm day (not Hot) is sitting on about 98 C not  towing the van. Have thought about a cooler and have mentioned it to Mazda but they said it was to hard, because the cooler was alongside of the transmission.

 

Thanx



#14 punchy

punchy

    First Gear

  • Full Member
  • PipPip
  • 10 posts

Posted 09 December 2015 - 08:18 PM

Fitted a transmission cooler to mine a few months back have checked temps with scan gauge it use to run around 97c with no load it runs between 86 & 89 now even when towing 1500 kg boat no issues work great

#15 hig70

hig70

    Zoom Zoom Zoom

  • Full Member
  • PipPipPip
  • 68 posts

Posted 05 January 2016 - 05:28 PM

Hi All,

As previously mentioned i had my trans replaced at 38k. Now 97k.Today while driving at 110 on the freeway my drive line light came on and i lost down change and appeared to have lost power. It appeared to go into limp mode. when i got off the free way i stopped. turned the engine off and restarted. light went out and drove normal. when heading home on the freeway the light came back on with same result. rang closest dealer told them i had a 2012 bt50 with this complaint and they said they were fully booked but i could drop it off and leave it all day they would look at it. on arrival at the dealer i was greeted in the drive and told as my car is now out of warranty i would have to book it in and that would be over a week.

i rang the selling dealer who is over an hour away they said they were full but bring it in and they would check for codes, but the trans sometimes dont code and if so they would have to drop pan and check oil and for metal in pan.

result is no code and they fully booked till next week.

they told me where to check oil which i did. found oil very dark maroon to black. i took a sample. they told me that likely new trans required.

this one only done 60k but out of warranty.

wait to see if im paying. dont think so..

 

Ian



#16 bucko

bucko

    100 kph

  • Full Member
  • PipPipPipPip
  • 156 posts
  • Location:NR Perth

Posted 06 January 2016 - 08:23 AM

Hi Ian ( hig70 )
Have you checked all intercooler hoses for leaks, loose clamps or splits..
As leaks will trigger drive line light
Is the auto making noises or bad gear changes ?
out of warranty don't bother with dealers go transmission shop for auto
Or a decent mechanics shop..
Just had my auto trans service at local trans shop @ 45k the 6r80 is a good box but life time service free is
Bull dust, if normal driving change trans fluid @ 50k and hard conditions and heavy towing would service ever 25k
And better oil cooler & pan with drain plug to save on future service costs
Ps I only go dealer for warranty work

#17 hig70

hig70

    Zoom Zoom Zoom

  • Full Member
  • PipPipPip
  • 68 posts

Posted 13 January 2016 - 10:47 AM

hi Bucko,

i checked intercooler hoses and clamps, all good.No noises or other gear change issues.

as the Trans is only 2.5 years old and 60k kms, was replaced at 13mths and 38k dealer stated they need to remove pan and check for metal in pan and oil quality. once thats done if there is an issue they will approach mazda.

My major issue with this limp mode is,

If your passing a truck on a single lane highway, the trucks doing 95kph and your doing 100kph then the BT goes into limp, you drop off to around 95kph with no power to pass. Your left next to a vehicle with the possibility of oncoming traffic.

This is what happened to me but i was lucky that i was on dual freeway, but i had cars following me and i couldnt pass. I had to put trans in N and turn off ignition and restart engine while going 95kph..



#18 Claybuster

Claybuster

    Second Gear

  • Full Member
  • PipPipPip
  • 26 posts

Posted 13 January 2016 - 12:49 PM

G'day there hig70,

you want to be careful the steering wheel does not lock turning the ignition of while moving, could be quite dangerous.



#19 bucko

bucko

    100 kph

  • Full Member
  • PipPipPipPip
  • 156 posts
  • Location:NR Perth

Posted 13 January 2016 - 01:32 PM

I wouldn't be turning off at highway speed, ok maybe once but we don't tow auto car on back wheels as damage to gear box.
If gearbox is ok, could be a sensor like crank angle sensor or plenty of others sensor which could play up but don't put up a fault code.
Damage flex plate from poor gearbox change

Good luck, hope it's not too many $$$

#20 willockwood

willockwood

    Newbie

  • Member
  • Pip
  • 2 posts

Posted 13 January 2016 - 03:39 PM

Hi "Gazza1"
Sorry for the late reply but have just returned from Darwin. Only issue to begin with was car lurching forward when put into drive. Mazda asked if I had after market suspension before they approved the replacement but they had modified my suspension under warranty so no way out there. Replacement is all good so far.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users